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[This Tutorial

m Class materials
web.mit.edu/acmath/matlab/coursel6/

m [0OpPICS
o MATLAB Review
o Exercise 1: Matrices & ODEs
o Introduction to Simulink
o Exercise 2: Simulink Model
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[Other References

m Mathematical Tools at Ml

web.mit.edu/ist/topics/math

o MATLAB Mastery | (beginners’ tutorial)
o Introduction to MATLAB (IAP series)

m MATLAB Tutorial for Unified
web.mit.edu/acmath/matlab/unified
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MATLAB Review

Interface

Matrices & Vectors
Built-In Functions

Script & Function M-files
Differential Equations

{_' Information Services I I-—
15 JIT

and Technology



[What IS MATLAB?

m Computational Software

From The MathWorks: www.mathworks.com

m Algorithm Development
Environment

m MATrix LABoratory
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[I\/IATLAB @ MIT

m On Athena
m 250 floating licenses (free)

m For student-owned computers
m 300 floating licenses (free)
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[Starting MATLAB

m On Athena
athena% add matlab

athena% matlab &
>> desktop

m On laptops

Desktop interface starts by default.

You must be running MATLAB now ...
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[Help in MATLAB

m Command line help
>> help <command>
e.g. help polyval
>> lookfor <keyword>
e.g. lookfor polynomial

m Help Browser
o Help->Help MATLAB
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[Variables ]
m Begin with an alphabetic character: a

m Case sensitive:a, A

m Data type detection: a=5; a=“ok”; a=1.3
m Default output variable: ans

Built-in constants:pr 1 J Inf

clear removes variables

who lists variables

Special characters
1 O {3 : % @
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Operators

m Arithmetic operators
+ - / \ ~ N\ / .* A
m Relational operators
< > <= >= == ~=
m Logical operators
| & || && true Talse
m Operator precedence
O {} [] -> Arithmetic -> Relational -> Logical

m Do not use special characters, operators,
or keywords in variable names.
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Numeric Data Types

m Notation
>> X = O;
>>y = 5.34;

>> z = 0.23e+3;
= Numeric manipulation
>> y = 5.3456; X = round(y);
>> format long
>> format compact

m Complex numbers
>> X = 5 + 61
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[Vectors

m Row vector
>> R1 = [1 6 3 8 5]

>> R2 = [1 : 5]

>> R3 = [-p1 - pi/3 : pi]
m Column vector

>> C1 = [1; 2; 35 4; 5]

>> C2 = R2°
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[I\/Iatrices

m Creating a matrix
> A =[12.550; 1 1.3 pi 4]
>> A = [R1; R2]

m Accessing elements
>> A(1,1); A(1:2, 2:4); A(:,2)
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[ Input / Output

m Import Wizard for data import
File->Import Data ..

m File input with Toad
B = load(“datain.txt?)

m File output with save
save(“dataout”, “A’, “-ascil’)
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[I\/Iatrix Operations

m Operators *, /7, and
>> Alnv = A™N-1 Matrix math is default!

m Operators + and -
>> X = [Xy X; X3];
>> Y = Ly; Y2 Yals
> A= X + Y
A =
X1ty Xoty,  X3ty;
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[EIement-Wise Operations

m Operators .*, ./,and .M
>> 72 = |z, z, z35])°
>> B = [Z.7M2 Z ones(3,1)]}

B =
Z,° 2z,
Z,*  Z,
Z3*  Z3
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Built-In Functions

m Matrices & vectors
>> [n, m]= size(A)
>> n = length(X)
>> M1 = ones(n, m)
>> MO = zeros(n, m)
>> En = eye(n); N1 = drag(En)
>> [evals, evecs] = ei1g(A)
>> det(A); rank(A); trace(A)

= And many others ...
>> y = exp(sin(x)+cos(t))
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Polynomials

s Evaluating polynomials

Y= pX"+ PX" e P X+ Py
>>p = [pl p2 .. ]
>t = [-3 - 0.1 : 3]
>> z = polyval(p, ©)
m Curve fitting
>> X = [xX1 x2 .. xn]; Y = [yl y2 .. yn]
>> Pm = polyfit(X, Y, m)
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[Integration & Differentiation ]

m Polynomial integration
[ pX" 4ot pX+ P dX=PX" 4 4P x+C

n+1

>> P = polyint(p); assumesC =0
m Area under a curve fromatob
>> area = polyval(P,b) - polyval(P,a)

m Polynomial differentiation

>> P = [P1 P2 .. Pn C]
>> p = polyder(P)
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2D Linear Plots

T

Command plot

>> plot (X, Y, “ro”)

>> plot (X, Y, “Color’, [0.5 O O], ..
“Marker”, “o”, ..
‘LineStyle”, “none’”)

Colors: b, r, g, , m, ¢, K,
Markers: o, *, ., +, X, d

Line styles: -, —--, -., -
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[I\/Iultiple Graphs on One Plot ]

m Built-in function hold
>> pl = plot(t, z, “r-7)
>> hold on
>> p2 = plot(t, -z, “b--7)
>> hold on
>> p3 = plot(T, Z, “go?)

>> hold off
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[Subplots on One Figure

If'

m Built-in function subplot

>> sl
>> pl
>> S2
>> p2
>> S3
>> p3

Information Services

and Technology

subplot(l, 3, 1)
plot(t, z, “‘r-7)
subplot(l, 3, 2)
plot(t, -z, “b--7)
subplot(l, 3, 3)
plot(T, Z, “go”)
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[Customizing Graphs ]

m Annotating graphs
>> plot (t, z, “‘r-7)
>> legend (“z=F(t)?)
>> title (“Position vs. Time?”)
>> xlabel (“Time?)
>> ylabel (“Position?)

= Plot Edit mode: icon | k|in Figure editor
m Property Editor: View->Property Editor
m Saving figures: File->Save As

I 5 Information Services I | I i I—

and Technology 16.06 & 16.07 MATLAB & Simulink Tutorials



M-File Programming

m Script M-Files
o Automate a series of steps.

o Share workspace with other scripts and the
command line interface.

m Function M-Files

o Extend the MATLAB language.

o Can accept input arguments and return
output arguments.

o Store variables in internal workspace.
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[A MATLAB Program

m Always has one script M-File

m Uses built-in functions as well as new
functions defined in function M-files

m Saved as <fFilename>.m

m To run: flename only (no .m extension)
>> <fi1lename>

m Created in Editor / Debugger
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[I\/I-File Editor / Debugger

m Create or open M-file in editor
>> edit <Filename>.m

m Type or copy commands
m Use % for comments

m Use ; to suppress output at runtime

s Debugging mode
K >> gg SN ER EREINEEE
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Variable Types

m Local (default)
o Every function has its own local variables.

o Scripts share local variables with functions they
call and with the base workspace.

m Global
global speedoflight

o Shared by functions, scripts, and base workspace.

m Persistent
persistent R, C

o Can be declared and used only in functions.

I 5 Information Services I | I i I—

and Technology 16.06 & 16.07 MATLAB & Simulink Tutorials



Program Flow Control

m 1T, elserfandelse

Example:

1t planet == 1, G = 9.814;
elself planet == 2, G = 3.688;
else G = 1nput(“Gravity: 7);
end

m switch and case

m for

m while
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Function M-File Example

See file: odeLanderVelocity.m

function DV = odelLanderVelocity(t, V)
% ODELANDERVELOCITY defines dV/dt for a Mars lander.
% This 1s help text for “help odelLanderVelocity”.

% The function’s body 1s below.

Gm = 3.688;

global K M

DV = Gm - K/M * VA2;
return
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[Differential Equations

m Ordinary Differential Equations
y'=1(t,y)

m Differential-Algebraic Expressions
M(t,y)y' = T(ty)

m Solvers for ODEs and DAEs
>> oded45; ode23; odell3d ..
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[ODE and DAE Solvers ]

>> [T, Y] = solver( , tspan, YO0)
B Syntax:

o solver: ode45, ode23, etc.

O - function handle

o tspan: interval of integration vector

>> tspan = [tO : tstep : tfinal]
o YO: vector of initial conditions
o [T, Y]: numerical solution in two vectors
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ODE Example

= Problem: dv(t):g_hvz

. dt m
m Solution:
global K M
K =1.2; % drag coefficient
M = 150; % mass (kg)
VO = 67.056; % velocity at t0O (m/s)
tspan = |[O - 0.05 : 6];
[t, V] = ode4d5( , .
tspan, VO)
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[Symbolic Math Toolbox ]

4
J

T

Incorporates symbolic computations into
MATLAB’s numerical environment

Functions access the Maple kernel
Constructs for symbolic values & expressions
>> X = sym(“x?)

>> F = sym(“cos(t)?)

>> syms a b c
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[Laplace Transforms ]

= Definition: F(s)=L{f(t)}= je‘“f(t)dt
m Examples:

o Laplace transform of f@)zsinﬁ)
>> F = sym(“sin(t)’)
>> F = laplace(T)
0.1

o Inverse Laplace transform of G (S)= 0 1s +1
>> G = sym(“0.1/(0.1*s+1) )
>> g = 1laplace(G)
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Transfer Functions

m System of linear differential equations
m State Space model

>.( — AX +Bu ,U&'Y: , Input & output vectors
, B & C: , Input & output matrices
Y =CX +Du D: usually zero (feedthrough) matrix

m [ransfer function

H =Num@)=c 5I-A) B=D
O-em)-cion

>> [Num, Den] = ss2tf(A, B, C, D)
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Exercise 1: Matrices & ODEs

m 1-A: Mars Lander Velocity
o Function file: odeLanderVelocity.m
o Script file: MarsLander.m

m 1-B: F-8 Longitudinal Time Response
o Function file: LongT imeResponse.m
o Script file: f81long.m

Follow Instructions Iin exercise handout
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Introduction to Simulink
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Simulations



[What IS Simulink?

|

m Software for modeling, simulating,

and analyzing dynamic systems
m Tool for model-based design

m MATLAB Toolbox -> access to all
MATLAB functions

I (T [nformation Services I I I i I—

and Technology 16.06 & 16.07 MATLAB & Simulink Tutorials



[Simulink @ MIT ]

m Comes with MATLAB

m On Athena
o 50 floating licenses (free)

m For student-owned computers

o 50 floating licenses (free)

o Student MATLAB Lite includes MATLAB,
Simulink, Control System, Optimization,
Signal Processing, Symbolic Math, Statistics
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[Starting Simulink

m Run MATLAB first ...

m Type in the Control Line Window
>> simulink

or ...

m Click on the Simulink icon
In the MATLARB toolbar ﬁ

You must be running Simulink now ...
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Simulink Libraries

SASRS) % Library: simulink
File Edit Wiew Furmai Help

wt W 2
e I A I I ot v I

Sources ainks Continuous Discrete  Discontinwities Signal Signal
Routinig Attributes

+ - £ TL £ |
L % EIE& == y=f{u} y=Tit,u} ®@ {E’;c o Mi=c
— == H
Math Logic and Bit Lookug Uzer-Defined Moclel Forts & Model-Yice
Operations Operations Takles Functions Verification  Subsystems |Hilities
Blocksets & COmmonly A dditional Math Simulinl_q Block Likbrary B.4 1
Toolboxes uzed blocks | & Discrete Demas Copyright (o) 1990-2008

The Mathwarks, Inc.
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Model Editor

m Creating a model: F1le->New->Model
m Saving a model: File->Save As

<modelname>._mdl
re C’ B % mymodel *

File Edit “iew Simulation Format Tools  Help
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Model Blocks: Sources

m Example: Step Function

'®06

File Edit Wiew Forms

% Library: simulink/Sources

: Help

1 F
b “EE" Constant
SOUFCES _/ !

I{.' Information Services
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signal Generators

oooao
oo F

Signal
Generator

ANES
A/

Sine YWave
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Model Blocks: Sinks

m Example: Scope

b T

—

FAN

ainks

806
File Edit Wiew Fom

% Library: simulink/Sinks

Help

Out

Model & Subsystem Outputs

Terminator

untitled rmat

sirnout

To File

Data Viewers

1] 1]
Scope Floating
Scope

1f“r'|nknmaﬁonSBHNQ£
1%

and Technology

Simulation Control
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Model Blocks: Math Operations

m Example: Sum

e 06 rary: simulink/Math Operations
Formal Help

{ / Math Operations
+ +
+ - ’@ N b o woo
= Sum Agddd Subtract Surn of Bis
* Elerments

kath =T
Operations )D} .l 1 f } ]_f }
Giain séigar Prociuct Diivvicle PErEc:#;:tgf ;
I~ | =
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Model Blocks: User-Defined
m Example: MATLAB function

& O O X/ Library: simulink/User-Defined Functions
File Edit Miew #omasi Help

e

|
User-defined Functions
J| MATLAE |
y=fltu} ] | MATLAE |, Furction
(3 Function v fen Wp
Fen MATLAE Fer MATLAE Fon
I lser-Defined Embecided
spstem | |_—h|
S-Function Lewel-2 M-file ystem :Z
S-Function

S-Function Builder
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Model Blocks: Continuous State

m Example: Transfer Function

™~

Continuous

File Edit

Wiewy  Foirmsl

) [X] Library: simulink/Continuous

Continuous-Time Linear 3yste

1

s+1

o Lk
5
Integrator
x' = A+ Bu 1 (=11
=N —
y = Lot 5+1 sfa+1)
State-Space Transfer Fon Zero-Fale
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Modeling: Block Diagram

m Example: Continuous System

rﬂ O 6 % mymodel *

File Edit Miew Simulation  Format Tools  Help

0ooo |
00 > »

a+1

Sigral Tranzfer Foh Scope
Generator

{.' Information Services N =
1% I

and Technology 16.06 & 16.07 MATLAB & Simulink Tutorials



Modeling: Block Parameters

ogooao
o0

Signal
Generator

re ) 7 || Function Block P

x€)_
(s,) s +2

Information Services
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151

Transter Fon Scope

eters: Transfer Fcn

—Transfer Fcn

The numerator coefficient can be a v
The denominator coefficient must be
equals the number of rows in the nu
should zpecify the coefficients in de

ror matrix expression.
ector. The output width
rator coefficient. You

ding order of powers of =.

/) /

—Parameters
Mumerator coefficient: _(/
|11

Denominator coefficient

I

Absolute folerance:

Iautc:

d

DK | gancell ﬂelpl gppIUJ

e
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Running Simulations

e

% mymodel *

File Edit Miew gimulatinn|Fgrmat Tools  Help ‘

ogooo r 806
1 -
00 —» — - ~ |5 |02 0 éidiE
Signal Transtfer Foh Scope
Generator

m  Configuration parameters

m  Run Simulation
Simulation -> Start
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[Exercise 2: Simulink Model ]

m -8 Controller Design
o Simulink file: ¥f8.mdl

Follow Instructions in exercise handout ...
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[Resc)urces

m web.mit.edu/ist/topics/math

m web.mit.edu/acmath/matlab/coursel6
m 16.060 TA: Tom Gray

m 16.07 TA: Shannon Cheng

Questions?
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